httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sagara Wijetunga <sagarali...@yahoo.com>
Subject Re: [users@httpd] Apache 2.0.50 configure script hangs [SOLVED]
Date Tue, 20 Jul 2004 03:52:13 GMT
--- Joe Orton <jorton@redhat.com> wrote:
> On Mon, Jul 19, 2004 at 09:19:36AM -0700, Sagara
> Wijetunga wrote:
> > Here are the outputs as you requested. I noticed
> this
> > is  something to do with the firewall. Later, I
> > disabled the firewall and ran the configure, it
> > worked. 
> 
> OK, that makes sense.  The test cases tries to make
> a connection so if
> the firewall rules prevent any packets from going
> even to loopback
> addresses it'll hang.  I'm not sure there's anything
> we can do about
> this other than perhaps document the case.
> 
> ... 
> > connect(4, {sa_family=AF_INET,
> sin_port=htons(32784),
> > sin_addr=inet_addr("0.0.0.0")}, 16) = -1 ETIMEDOUT
> 

The Apache 2.0.50 configure script hangs was due to
misconfigured firewall. 

Packets to loopback interface must be allowed in the
INPUT/OUTPUT channels. In my firewall, it was allowed
in the wrong place in INPUT channel.

Thank you very much for helping me to identify the
cause.

Kind regards
Sagara


		
__________________________________
Do you Yahoo!?
Yahoo! Mail Address AutoComplete - You start. We finish.
http://promotions.yahoo.com/new_mail 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message