httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Batara Kesuma <bkes...@ml.gaijinweb.com>
Subject [users@httpd] KeepAlive and server performance
Date Wed, 07 Jul 2004 05:52:46 GMT
Hi,
I use Apache Worker MPM to serve all images from site. My setting looks
like:
<IfModule worker.c>
StartServers         2
MaxClients         200
MinSpareThreads     25
MaxSpareThreads     75
ThreadsPerChild     25
MaxRequestsPerChild  0
</IfModule>

The server-status at some random time looks like:
11 requests currently being processed, 64 idle workers
12 requests currently being processed, 63 idle workers
17 requests currently being processed, 58 idle workers

I read about KeepAlive, and it is said that setting KeepAlive On can
speed up the latency times for HTML with many images. I tried to set
KeepAlive On on my image server, but the result was much much slower.
My setting was like:
KeepAlive Off
KeepAliveTimeout 10
MaxKeepAliveRequests 50

The server-status was full of K (Keepalive Read) signs. Did I do
something wrong?

Thanks in advance,
Batara

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message