httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jos...@slive.ca>
Subject Re: [users@httpd] Error logs showing status 304 for images. Why?
Date Tue, 01 Jun 2004 17:50:44 GMT

On Tue, 1 Jun 2004, Gerard Isdell wrote:
> Some visitors to my website are complaining that sometimes they can't see
> images on the site.  I've looked in the error logs and found lots of GETs of
> images with a status code of 304 e.g.
>
> 80.41.236.203 - - [27/May/2004:21:20:24 +0000] "GET
> /members/photos/alexpic3.jpg HTTP/1.1" 304 - "Mozilla/4.0 (compatible;
> MSIE 6.0; Windows 98; generic_01_01)"
>
> As far as I can make out, this is an issue in which the server responds with
> the 304 code, essentially saying the image hasn't been modified, and telling
> the browser to use the version in it's cache.

The 304 status code is perfectly normal, so you need to look a little 
deeper.  What exact problem are you seeing?  Have you examined exactly the 
headers that are being sent in the HTTP request and response?  If you 
"touch" the file (to make the server think it changed) can the client get 
the image?

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message