httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brent Bailey" <bbai...@metrocastcablevision.com>
Subject [users@httpd] error message when compiling apache
Date Mon, 14 Jun 2004 19:03:11 GMT
Hello,
Im trying to compile from source of apache on a solaris 9 machine. Wht im 
actually looking to do is to get apache compiled with

OpenSSl
mod_ssl
mod_perl

Ive already gone and installed openssl then ./configured both mod_ssl by doing

./configure --with-apache=../apache_1.3.27 --with-eapi-only

then i went to the mod_perl dir and did:

perl Makefile.PL APACHE_SRC=../apache_1.3.xx/src \
    DO_HTTPD=1 USE_APACI=1 EVERYTHING=1

so then i went to the apache src dir and did:

./configure --prefix=/usr/local/apache --enable-module=all --enable-
shared=max --enable-rule=EAPI --with-layout=Apache

I then got the following error:

Error: None of Berkeley-DB 1.x, 2.x or 3.x libraries found.
       Either disable mod_auth_db or provide us with the paths
       to the Berkeley-DB include and library files.
       (Hint: INCLUDES, LDFLAGS, LIBS)


Im not sure wheres these libraries are on a solaris 9 machine ?!?

any help is greatly appreciated

thank you 
Brent Bailey 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message