httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Orton <jor...@redhat.com>
Subject Re: [users@httpd] Apache 2.0.49 flushing CGI script causes huge memory consumption
Date Tue, 01 Jun 2004 13:39:03 GMT
On Mon, May 31, 2004 at 09:54:06PM +0100, Nick Kew wrote:
> On Mon, 31 May 2004, David Greenaway wrote:
> 
> > I switched to mod_cgid, giving no change. I then tried your suggestion
> > of looking at my output filters, and found that mod_deflate seems to be
> > the culprit: Removing it makes allows the page to be served without
> > the server blinking.
> 
> Your original post refers to printing "foo" 100000 times with
> output buffering suppressed.
> 
> I was wondering idly if that became 100000 3-byte buckets - maybe
> even with each having its own brigade - within Apache.  That would
> certainly be inefficient, and would give a reason why mod_deflate
> might blow up[1].

It seems like the memory consumption is simply because mod_deflate does
not destroy the buckets it is compressing along the way! David filed
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=29318 on this, I've
added a pointer to a 2.0 patch for this.

Regards,

joe

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message