httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Andersson" <rob...@profundis.nu>
Subject Re: [users@httpd] Please help: Apache uses up all available servers and hangs until restart
Date Thu, 24 Jun 2004 13:51:18 GMT
John Flaxen wrote:
> I have attached three files. Server-info.txt is the server-info from the
> server. Server-status-problem is what server-status during the problem
> looks like, and server-status-normal is when its operating normally.

The problematic server-status looks similar to what I and others have
experienced. You may want to look at the "Server Load Issue" thread from
about a week ago:
    http://marc.theaimsgroup.com/?t=108740466900002&r=1&w=2

> Srv PID Acc M CPU  SS <snip>
> 0-1 3266 0/2/2 W  0.26 3850 <snip>
> 1-1 3816 0/4/6 W  0.14 1681 <snip>
> 2-1 3268 0/3/3 W  0.33 4006 <snip>

This is what I have from time to time too, and I find it weird. A request
that has been in W (sending reply) for 4000+ seconds; and I'm sure it isn't
a slow connection issue, it is rather stucked there.

I don't get this very often, perhaps once a month and then it goes away
after a while, so I haven't been able to troubleshot it very well.

I don't know how (have time) to figure this out, but just letting you know
that you're not alone. You may be able to breath some live into that other
thread.

Regards,
Robert Andersson


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message