httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Andersson" <rob...@profundis.nu>
Subject Re: [users@httpd] using ReWrite rules in W32
Date Sat, 19 Jun 2004 22:04:48 GMT
[plain text, please...]

Norman Peelman wrote:
> What I shopuld have asked is what is required to get
> ReWrite up and running on Apache2/Win32.

You should also have said what version of Apache 2.0 and how you got it.
Official binary from ASF?

AFAIK, the Windows binary comes with mod_rewrite as a shared module, so all
you need is to uncomment the LoadModule statement in httpd.conf to enable
mod_rewrite.

> I am loading the module but nothing seems to happen. I've got
> my rewrite rules within <ifModule> tags and I don't think the
> module is working because if I remove the <ifModule> tags then
> Apache will not restart.

Remove the <IfModule> tags, they will just obscure problems.

What is the exact problem when trying to start Apache with those rewrite
rules? Try going to Apache's bin directory in a "command prompt" and then
running "apache -t", which will report any problems with the config. Post
back the *exact* error message if any.

Regards,
Robert Andersson


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message