httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Volker Haug <volker.h...@waldbrenner.de>
Subject RE: AW: [users@httpd] Re: Cannot start Apache 2.04 on Windows ME
Date Fri, 28 May 2004 16:09:05 GMT
OK, I think i fixed the problem with my messages, but my problem with apache
2.0.49 isn't fixed. I've only one apache installed and there is no other
Apache running. 

I've all messages added to this message.

volker

-----Original Message-----
From: Robert Andersson [mailto:robert@profundis.nu]
Sent: Friday, May 28, 2004 5:39 PM
To: users@httpd.apache.org
Subject: Re: AW: [users@httpd] Re: Cannot start Apache 2.04 on Windows
ME


Volker Haug wrote:
> I don't think so; how can I check this; there is nothing on the systray
> like apache; that's not the solution.

The only systray thing with Apache is Apache Service Monitor (which is not
Apache itself, but a monitor of Apache). It is only meaningful when Apache
is running as a service. Does Win ME has services?

There are a few ways to check if Apache is running.
1) Enter http://127.0.0.1:8080/ (or whatever port you're checking) in
   a browser.
2) Check a process listing (task manager, or something), and look for
   Apache.exe

Btw, your messages seems to be mangled (at least the ones I get); they lack
an empty line between headers and body. Not sure what might causing it;
might be my MTA or something but it's the first time I see it.

Regards,
Robert Andersson


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org



-----Original Message-----
From: Luis Moreira [mailto:luis.moreira@esinnovation.pt]
Sent: Friday, May 28, 2004 5:13 PM
To: users@httpd.apache.org
Subject: Re: AW: AW: [users@httpd] Re: Cannot start Apache 2.04 on
Windows ME


Volker Haug wrote:

>I don't think so; how can I check this; there is nothing on the systray
like
>apache; that's not the solution.
>
>-----Ursprüngliche Nachricht-----
>Von: Robert Andersson [mailto:robert@profundis.nu]
>Gesendet: Freitag, 28. Mai 2004 16:05
>An: users@httpd.apache.org
>Betreff: Re: AW: [users@httpd] Re: Cannot start Apache 2.04 on Windows
>ME
>
>
>Volker Haug wrote:
>  
>
>>C:\Programme\Apache Group\Apache2\bin>apache
>>[Fri Jan 09 01:15:02 2004] [crit] (OS 10038)Socket operation on
>>    
>>
>non-socket:
>  
>
>>make_sock: for address 0.0.0.0:8080, apr_socket_opt_set: (SO_KEEPALIVE)
>>no listening sockets available, shutting down
>>Unable to open logs
>>    
>>
>
>You are probably still running an instance of Apache on that IP+port
>combination.
>
>Regards,
>Robert Andersson
>
>
>---------------------------------------------------------------------
>The official User-To-User support forum of the Apache HTTP Server Project.
>See <URL:http://httpd.apache.org/userslist.html> for more info.
>To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
>For additional commands, e-mail: users-help@httpd.apache.org
>
>---------------------------------------------------------------------
>The official User-To-User support forum of the Apache HTTP Server Project.
>See <URL:http://httpd.apache.org/userslist.html> for more info.
>To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
>For additional commands, e-mail: users-help@httpd.apache.org
>
>
>  
>
First, are you sure you use port 8080 ? The message says "no listening 
sockets available".
Second, this is not the first time this issue is adddressed here.
If you "google" for the term "Socket operation on non-socket" you find 
lots of sites that report that problem, and mention network problems.

Don't mean to say you haven't done this already, but triple check your 
config.
Maybe there is something missing...

Luis


-----Original Message-----
From: Joshua Slive [mailto:joshua@slive.ca]
Sent: Wednesday, May 26, 2004 5:04 PM
To: 'users@httpd.apache.org'
Subject: Re: AW: [users@httpd] Re: Cannot start Apache 2.04 on Windows
ME



On Wed, 26 May 2004, Volker Haug wrote:

> this is an invalid command for my installation of Apache 2.0.48.
> Is there anything else what I had to do?

Upgrade to 2.0.49.  See the "compatibility" line:
http://httpd.apache.org/docs-2.0/mod/mpm_winnt.html#win32disableacceptex

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org



-----Original Message-----
From: Volker Haug 
Sent: Wednesday, May 26, 2004 5:00 PM
To: 'users@httpd.apache.org'
Subject: AW: [users@httpd] Re: Cannot start Apache 2.04 on Windows ME


this is an invalid command for my installation of Apache 2.0.48.
Is there anything else what I had to do?

Volker

-----Ursprüngliche Nachricht-----
Von: Martin Lomas [mailto:mlomas@rogers.com]
Gesendet: Mittwoch, 26. Mai 2004 16:31
An: users@httpd.apache.org
Betreff: [users@httpd] Re: Cannot start Apache 2.04 on Windows ME


This is a shot in the dark - something I read elsewhere that has helped at
least a couple of Windows 98 users anyway, so maybe? The advice is:

Add..

Win32DisableAcceptEx on

.. to the end of your httpd.conf configuration file.

Good luck!
Martin

> Date: Tue, 25 May 2004 19:12:15 +0200
> To: "'users@httpd.apache.org'" <users@httpd.apache.org>
> From: Volker Haug <volker.haug@waldbrenner.de>
> Subject: AW: [users@httpd] Cannot start Apache 2.04 on Windows ME
> Message-ID: <75BDB29A28CBD211BD6C00600853781401895150@waldbrenner.de>
>
> Hallo,
>
> I have also the problem with Apache 2.0.4x and Windows ME. In my =
> httpd.conf
> file there is no entry "BindAddress" an I'm not using IIS. I have a =
> Standard
> Installation fpr Windows ME (german) and Apache 2.0.4x on Port 8080. I
> search the Internet but noone can help to this problem, which exist =
> although
> under Windows 98.
>
> I have installed no firewall or antivirus software. I have installed a
> LAN-Card with a Windows an a Novell-Client over TCP/IP.
>
> Can anyone help?
>
> Volker


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org



-----Original Message-----
From: Volker Haug 
Sent: Tuesday, May 25, 2004 7:12 PM
To: 'users@httpd.apache.org'
Subject: AW: [users@httpd] Cannot start Apache 2.04 on Windows ME


Hallo,

I have also the problem with Apache 2.0.4x and Windows ME. In my httpd.conf
file there is no entry "BindAddress" an I'm not using IIS. I have a Standard
Installation fpr Windows ME (german) and Apache 2.0.4x on Port 8080. I
search the Internet but noone can help to this problem, which exist although
under Windows 98.

I have installed no firewall or antivirus software. I have installed a
LAN-Card with a Windows an a Novell-Client over TCP/IP.

Can anyone help?

Volker

-----Ursprüngliche Nachricht-----
Von: Ken Osman [mailto:ken.osman@ntlworld.com]
Gesendet: Donnerstag, 15. Januar 2004 10:19
An: users@httpd.apache.org
Betreff: Re: [users@httpd] Cannot start Apache 2.04 on Windows ME


Bryan
 Thankyou for taking the trouble to reply.

For various reasons I would like to try Apache but might give up soon!

I have tried not using a bind address but without result

Ken
----- Original Message ----- 
From: "Bryan Irvine" <bryan.irvine@kingcountyjournal.com>
To: <users@httpd.apache.org>
Sent: Wednesday, January 14, 2004 5:25 PM
Subject: Re: [users@httpd] Cannot start Apache 2.04 on Windows ME


> Shouldn't you be using IIS?  ;-)
>
> Try not using "BindAddress" in your httpd.conf.
>
> --Bryan
>
>
> > I get corresponding versions of error "OS10038 socket operation on non
> > socket make-sock  : for address 0.0.0.0:80, apr-socket-opt-set :(SO
> > KEEP ALIVE)
> > no listening sockets available, shutting down unable to open logs"
>
>
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message