httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Florian Effenberger <flo...@arcor.de>
Subject Re: [users@httpd] PHP as CGI becomes a zombie when loaded too often
Date Fri, 28 May 2004 14:59:42 GMT
Hi Eugene,

> 1) Any interesting messages in error_log ?

Only "Premature end of script headers" and "child process 4207 still did 
not exit, sending a SIGTERM".

> 2) Does it happen regardless of the Apache 2.x MPM chosen?

Will try the other ones out now, have only tested prefork for now.

> 3) phpinfo() is a bit intensive.  Do simple PHP scripts cause the same
> problems, e.g. "<?php print '0'; ?>" ?

This simple script leads to the same problem as well. I guess its the 
hughe PHP binary (although I've compiled with only minimal options, so 
no big modules are included).

> 4) How about on another flavor of Linux, maybe something 2.6-ish?

Tried 2.6.5, same problem. :-(

> 5) How about another Unix OS, e.g. *BSD ?

Had no time to test this. However, I'll have to stay with Linux at the 
moment.

Florian

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message