httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From BAO RuiXian <ruixian....@pp.inet.fi>
Subject Re: [users@httpd] authentication trouble
Date Fri, 14 May 2004 17:22:36 GMT


Noel Leistad wrote:

> Apache 2.0.48 on FC1, also Apache 2.0.46 on RHEL3 same problems with 
> each.
>
> Am trying to add auth to a directory. Followed directions for auth on 
> httpd2.0 doc site.
>
> I have configured a site. Access site. Add directory to site, access 
> directory.
>
> Add
> <Directory directory>

Please make it as <Directory /var/www/directory. For Directory 
directive, the value is the whole system path.

Best

Bao

> AuthType Basic
> AuthName "Login Test"
> AuthUserFile /var/htpasswd
> Require valid-user user
> </Directory>
>
> service httpd reload, also tried restart
>
> Attempt to access gives "You don't have permission to access 
> /directory/ on this server."
>
> error_log shows "client denied by server configuration: 
> /var/www/directory/"
>
> Removed above <Directory.... /Directory>, service httpd reload -- 
> still no permission. service httpd restart -- still no permission. 
> Closed browser, re-opend -- still no permission.  error_log entry 
> repeats as above.
>
> I'm sure it's something simple, but can't see. Actually have a "Auth" 
> site on the RHEL3 box that is working, copied it's config and modified 
> specifics, still doesn't work.
>
> Any indication as to next step in diagnosis greatly appreciated.
>
> TIA
>
> Noel
>
>


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message