httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brent 'Dax' Royal-Gordon <br...@brentdax.com>
Subject Re: [users@httpd] problem serving Arabic pages
Date Tue, 11 May 2004 14:45:54 GMT
JNelson@uaeu.ac.ae wrote:
> Hello,
> 
> I'm having trouble getting Apache to serve Arabic language pages.  
 > When the html file is loaded locally, it is recognized as Arabic and
 > the Arabic script appears.  But when it's loaded through Apache, the
> browser recognizes it as the wrong character set.  
> 
> Here is the page I'm trying to get to work:
> http://www.ugruenglish.uaeu.ac.ae/arabic/Main

When I look at this page in Mozilla Firefox, it comes up with mostly 
junk text; looking at the properties, it says the charset is ISO-8859-1. 
  If I force the character set to Windows-1256 (as in the file's <meta> 
tag), it displays Arabic text, although I can't verify that it's the 
*right* Arabic text.

This is a guess, but it might help to change httpd.conf line 819:

AddDefaultCharset on

To this:

AddDefaultCharset windows-1256

If only some directories or virtual hosts should have this set, the 
Apache 1.3 docs indicate that AddDefaultCharset is legal within a 
<Directory>, <Location>, <VirtualHost>, or <Files> block, or a .htaccess

file.

HTH,
-- 
Brent "Dax" Royal-Gordon <brent@brentdax.com>
Perl and Parrot hacker

Oceania has always been at war with Eastasia.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message