httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg Miell" <greg_mi...@dsl.pipex.com>
Subject RE: [users@httpd] DAV - Problems uploading...
Date Thu, 06 May 2004 16:49:57 GMT
Ok, I cleared my logs and opened a webdav connection to the server. This is
the following of my access/error logs:
Access.Log:

169.254.207.30 - - [06/May/2004:17:42:10 +0100] "PROPFIND /davtest HTTP/1.1"
207 825
169.254.207.30 - - [06/May/2004:17:42:10 +0100] "PROPFIND /davtest HTTP/1.1"
207 3296
169.254.207.30 - - [06/May/2004:17:42:49 +0100] "HEAD /davtest/FacePic.jpg
HTTP/1.1" 302 -

Error.Log:

[Thu May 06 17:39:50 2004] [warn] Init: (domain.net:443) You configured
HTTP(80) on the standard HTTPS(443) port!
[Thu May 06 17:39:50 2004] [warn] Init: (domain.net:443) You configured
HTTP(80) on the standard HTTPS(443) port!
[Thu May 06 17:39:50 2004] [notice] Digest: generating secret for digest
authentication ...
[Thu May 06 17:39:50 2004] [notice] Digest: done
[Thu May 06 17:39:50 2004] [notice] Parent: Created child process 3464
[Thu May 06 17:39:51 2004] [warn] Init: (domain.net:443) You configured
HTTP(80) on the standard HTTPS(443) port!
[Thu May 06 17:39:52 2004] [warn] Init: (domain.net:443) You configured
HTTP(80) on the standard HTTPS(443) port!
[Thu May 06 17:39:52 2004] [notice] Digest: generating secret for digest
authentication ...
[Thu May 06 17:39:52 2004] [notice] Digest: done
[Thu May 06 17:39:52 2004] [notice] Child 3464: Child process is running
[Thu May 06 17:39:52 2004] [notice] Child 3464: Acquired the start mutex.
[Thu May 06 17:39:52 2004] [notice] Child 3464: Starting 250 worker threads.
[Thu May 06 17:42:49 2004] [error] [client 169.254.207.30] File does not
exist: W:/wwwSecure/davtest/FacePic.jpg

Greg Miell 

Dell Dimension 2350

2.5GHz Intel Pentium 4

1GB SDRAM

Intel Graphics -> Dell 17in CRT

Matrox Mystique Graphics -> Compaq 15in CRT

1xDVD-ROM

1xCR-RW

1x120GB HDD

1x200GB HDD

6xUSB

1xNIC -> ADSL Router


-----Original Message-----
From: John P. Dodge [mailto:dodge@cruciate.ca.boeing.com] 
Sent: 06 May 2004 15:00
To: users@httpd.apache.org
Subject: RE: [users@httpd] DAV - Problems uploading...

On Thu, 6 May 2004, Greg Miell wrote:

> Ok I have tested this again, and got some consistent log data:
>
> Access.log:
> 169.254.207.30 - - [06/May/2004:08:16:24 +0100] "HEAD /davtest/FacePic.jpg
> HTTP/1.1" 302 -
>
> Error.Log:
> [Thu May 06 08:16:24 2004] [error] [client 169.254.207.30] File does not
> exist: W:/wwwSecure/davtest/FacePic.jpg
>
> So I'm not sure whats going on any more! Apparently the file not existing
> creates a 302?! Mayb its my config?
>
>
> The access log entry is not consistent with the error log.  The times are
> wrong, and the "302" status code would not give "file does not exist".
>
> Joshua.
>
This does not look like a WebDAV request sequence, I don't see any WebDAV
methods in the access log (PROPFIND, OPTIONS, ...).  Can you retrieve this
file in the browser?

As Joshua said the 302 response code does not return a "file not found".


----------------------------------------
"Mon aƩroglisseur est plein d'anguilles"
John P. Dodge
Boeing Shared Services


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message