httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg Miell" <greg_mi...@dsl.pipex.com>
Subject RE: [users@httpd] DAV - Problems uploading...
Date Thu, 06 May 2004 07:21:09 GMT
Ok I have tested this again, and got some consistent log data:

Access.log:
169.254.207.30 - - [06/May/2004:08:16:24 +0100] "HEAD /davtest/FacePic.jpg
HTTP/1.1" 302 -

Error.Log:
[Thu May 06 08:16:24 2004] [error] [client 169.254.207.30] File does not
exist: W:/wwwSecure/davtest/FacePic.jpg

So I'm not sure whats going on any more! Apparently the file not existing
creates a 302?! Mayb its my config?

<VirtualHost *:443>
    ServerName secure.domain.net
    ServerAlias secure.domain.net
    SSLEngine On
    SSLCertificateFile W:/SSLCert/my-server.cert
    SSLCertificateKeyFile W:/SSLCert/my-server.key
    DocumentRoot "W:/wwwsecure"
    ScriptAlias /cgi-bin/ "W:/ScriptsSecure/"
    Alias /admin "W:/wwwadmin"
    ScriptAlias /admin/cgi-bin/ "W:/ScriptswwwAdmin/"

#    ProxyPass /admin/router http://169.254.207.29/
#    ProxyPassReverse /admin/router http://169.254.207.29/
#    ProxyPass /admin/DUpdate http://169.254.207.30:9980/
#    ProxyPassReverse /admin/DUpdate http://169.254.207.30:9980/

    <Location /davtest>
#        Options Indexes FollowSymLinks
#        AllowOverride None
#        Order allow,deny
#        Allow from all

#        AuthType Basic
#        AuthName "DavTest"
#        Require valid-user
#        AuthMySQLHost localhost
#        AuthMySQLDB ApacheAuth
#        AuthMySQLUser PHP
#        AuthMySQLPassword phppwd
#        AuthMySQLUserTable user_info
#        AuthMySQLNameField user_name
#        AuthMySQLPasswordField user_passwd
#        AuthMySQLCryptedPasswords Off
#        #AuthUserFile W:/Auth/davtest.pass
#        #Require user admin
        Dav On
        DavMinTimeout 600
    </Location>

    <Directory "W:/users/*">
        AllowOverride AuthConfig
        Dav On
        <LimitExcept HEAD GET OPTIONS>
            AuthType Basic
            AuthName "Please enter your account name and password"
            Require user Administrator
            AuthMySQLHost localhost
            AuthMySQLDB ApacheAuth
            AuthMySQLUser Apache
            AuthMySQLPassword 2e1hkq2k
            AuthMySQLUserTable user_info
            AuthMySQLNameField user_name
            AuthMySQLPasswordField user_passwd
            AuthMySQLCryptedPasswords Off
        </LimitExcept>
        DavMinTimeout 600
    </Directory>

    <Location /users>
        AuthType Basic
        AuthName "Please enter your account name and password"
        Require valid-user
        AuthMySQLHost localhost
        AuthMySQLDB ApacheAuth
        AuthMySQLUser Apache
        AuthMySQLPassword 2e1hkq2k
        AuthMySQLUserTable user_info
        AuthMySQLNameField user_name
        AuthMySQLPasswordField user_passwd
        AuthMySQLCryptedPasswords Off
    </Location>

    <Location /admin>
        RewriteEngine On
        RewriteCond %{QUERY_STRING} todo=logout [NC]
        RewriteRule ^/admin/router(.*)  /admin? [PT]

        RewriteRule ^/admin/dupdate(.*) http://169.254.207.30:9980$1 [P]
        RewriteRule ^/admin/router/start(.*) http://169.254.207.29$1 [P]
        RewriteRule ^/admin/router(.*) http://169.254.207.29$1 [P]
    </Location>
</VirtualHost>

Greg Miell

+447763909283

http://www.domain.net

telnet://bbs.domain.net

 

Dell Dimension 2350

2.5GHz Intel Pentium 4

1GB SDRAM

Intel Graphics -> Dell 17in CRT

Matrox Mystique Graphics -> Compaq 15in CRT

1xDVD-ROM

1xCR-RW

1x120GB HDD

1x200GB HDD

6xUSB

1xNIC -> ADSL Router

-----Original Message-----
From: Joshua Slive [mailto:joshua@slive.ca] 
Sent: 05 May 2004 23:45
To: users@httpd.apache.org
Subject: RE: [users@httpd] DAV - Problems uploading...


On Wed, 5 May 2004, Greg Miell wrote:

> The server's access.log contains an entry for:
> 169.254.207.30 - - [05/May/2004:21:04:48 +0100] "HEAD /%7Egreg/FacePic.jpg
> HTTP/1.1" 302 -
>
> I am using Windows XP web folders to access this DAV directory, if that
> makes any difference...

> On Wed, 5 May 2004, Greg Miell wrote:
> > This config worked fine until this morning, now when I try to upload a
new
> > file eg facepic.jpg I get the following in error.log:
> > [Wed May 05 17:50:58 2004] [error] [client 169.254.207.30] File does not
> > exist: C:/Inetpub/wwwSecure/davtest/FacePic.jpg
> >
> > I don't understand why the server is thinking that I'm requesting the
file
> > and not uploading it.

The access log entry is not consistent with the error log.  The times are
wrong, and the "302" status code would not give "file does not exist".

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message