httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joseph A. Nagy, Jr." <jnag...@joseph-a-nagy-jr.homelinux.org>
Subject Re: [users@httpd] 403 Denied[solved]
Date Sun, 02 May 2004 12:17:25 GMT
On Sun, May 02, 2004 at 02:20:22AM -0400, Leif W wrote the following:
> Well, look, I'm not going to argue with you, you asked for help and I'm
> just trying to help.  You said "all the folders in question", but you
> failed to list explicitly which folders YOU consider to be in question,
> as opposed to which folders someone else might realize that APACHE
> considers to be in question, which is what ultimately matters.  Even if
> it seems basic, it's best to start at the beginning and not make
> assumptions about what you're considering, what the software considers,
> and how other people might interpret an ambiguous description.  :-)

Sorry.

> 
> From the description you provided, and from what Apache is saying in the
> logs, and to the browser, it appears to be a problem where Apache is
> refusing to let the client see something.  After playing with my file
> and directory permissions on the assumption that it wasafilepermissions
> error, I noticed that the file permission error is differnt from the
> error log entry you reported.  I found out that I can get this same
> error message as you in my log file, and the same error in my browser.
> This is probably your problem.  What I did was set "Order deny,allow"
> and "Deny from all".  It's an extreme case, but you may have something
> related to your deny vs. allow, or ordering, which may be more subtle?
> I.e. default behaviour, as you have nothing specified in that
> <Directory> tag.  Try the following example.Also note, 1) your
> DocumentRoot location must match your Directory location, 2) You
> directory location was / (root),which is probably a BAD idea (typo in
> the email?), 3) the <Directory> parameter should be double-quoted, and
> have no trailing / (which is impossible when you try to use / ).  You
> probably need something like this, shown below.
> 
> <Directory "/path/to/public_html">
>        Options All Multiviews
>        Order allow,deny
>        Allow from all
> </Directory>
> 
> Leif
> 

That's odd because I don't have that problem elsewhere with the same setup.
Hrm. *adjusts and tests*

<VirtualHost *>
   ServerAdmin c_sage@charter.net
   DocumentRoot /home/csage/public_html/
   ServerName charles-sage.homeip.net
   CustomLog /path/to/logs/charles-sage.access.log combined
   ErrorLog /path/to/logs/charles-sage.error.log
 <Directory "/home/csage/public_html">
        Options All Multiviews
	Order allow,deny
	Allow from all
 </Directory>
</VirtualHost>
<snip>

That worked oddly enough. I'm not sure why this vhost would need tha
allow,deny setup when the others don't but eh, it works. *waves dead
chicken* Thanks for the help and sorry that I was an ass.
-- 
Joseph A. Nagy, Jr. http://joseph-a-nagy-jr.homelinux.org
Political Activist Extraordinaire	Peace, Life, Liberty
"The only fallacy is the inaction on our part to stave off the worst of 
horrors, the stripping of personal freedom." -- Joseph A. Nagy, Jr. January 2004

Mime
View raw message