httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "benjamin" <bsch...@wanadoo.fr>
Subject Re: [users@httpd] Curious problem
Date Tue, 11 May 2004 17:22:24 GMT
hi,

In reality in my php.ini file, the max_execution_time was set at 10s , I find that strange
for it, (I deactivated ini_set function,  does it exist another function for disabling the
max_execution_time limit ?)

Effectively on the mysql server there are some mysql process which take a lot of cpu during
the same time.
But how can I find the script or the mysql request concerned ?

"You might also grep logs for 206 (partial content) and see if that corresponds with what
you're seeing."
ok, but where I can look this logfile ? (it's an apache or a mysql log file ?)

thank you for your help ;)

benjamin

  ----- Original Message ----- 
  From: Tim Burden 
  To: users@httpd.apache.org 
  Sent: Monday, May 10, 2004 11:24 PM
  Subject: Re: [users@httpd] Curious problem


  hi,

  An infinite loop in PHP would cause the symptoms you describe. But only if your php.ini
max_execution_time was set at 0, or some very high number. Or was being overridden.

  Also, a poor mysql query might do this, since the mysql server is on a different machine.
PHP does not seem to count the time waiting for mysql_query() to return in its calculation
of script execution time. So next time it happens, top the other server for big honkin mysqld
processes.

  You might also grep logs for 206 (partial content) and see if that corresponds with what
you're seeing.
    ----- Original Message ----- 
    From: benjamin 
    To: users@httpd.apache.org 
    Sent: Monday, May 10, 2004 2:38 PM
    Subject: [users@httpd] Curious problem


    hello,

    I use a server (debian) to host some sites (php forum...).
    From time to time (it is very unpredictable) there is several process Apache which take
100 % of the cpu, and the server becomes down in Web.
    Even after having killed the concerned process, other process (with a different pid number)
appear also by taking 100 % of the cpu. 
    The only mean which I found it's to " killall 9 httpd " and to relaunch Apache normally,
and that Work again

    It is a standard Apache / php configuration.
    ( Just a detail, mysql is situated on an other server )

    I think of a bad script php (like infinite buckles), possible?
    But how avoid that the server is down ? Or how track down the defective script?

    Thank you for your help

    Ps: I looked during many hours of the identical cases on google but nothing is equivalent


    Good evening;)

Mime
View raw message