httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Peterson" <dcpe...@lauper.org>
Subject [users@httpd] 2.x SSI and Restart no longer working on Win XP
Date Mon, 03 May 2004 02:19:03 GMT
Summary:
SSI (Server Side Includes) was working fine for Apache version 2.0.48 on Windows XP.
SSI stops working after other software updated(?)
New install of Version 2.0.49 fails in same way.
XP SP1 resolves nothing.
New installation of Version 1.3.29 works fine.
Also: Restart on 2.x versions no longer works: no error, but browser times out.

I can't seem to find anything relevant in the archive (can't search on XP?!)

I had SSI working WITHOUT PROBLEM with a localhost testbed server version 2.0.48 on Windows
XP Professional. SSI stopped working, without any changes to httpd.conf.  Now, any .shtml
page that contains an SSI directive completely fails and returns "nothing" to the browser.
 (If it is returning "something", it is being interpreted by the browser as "not-displayable".)

However, other software on the system has been changed...
I am suspecting that an incompatibility has been introduced by upgrading OTHER software, since
I did not change anything with the Apache configuration.

Unfortunately, I cannot provide the exact cause-effect scenario because I went three weeks
without using the Apache server.  During that time, I upgraded my .Net framework to version
1.1 and upgraded to Visual Studio for .Net 2003.  The latter required that I install Internet
Explorer 6's SP1 patch.  I also upgraded my existing SystemSuite version 4 (from Vcom) to
version 5.  Before and after, the only background virus checking is for email attachments,
NOT every file opened.  The firewall is turned off.

It was at that point that I tried to use the Apache server again and found that none of the
.shtml pages work anymore (99% of the pages on the site are .shtml).  Regular html pages continue
to work fine.  I created a very basic .shtml with a single SSI directive (<!--#echo var="DATE_LOCAL"
-->).  Initially (on 2.0.48), I could get it to work partially: at the top of the page,
the browser would display what looked like some http header information, followed by the actual
page contents, including the results of the #echo directive, but then it would stop after
only displaying part of the rest of the page.

On the Apache site I noted that there was new version, 2.0.49.  I decided to download that
and install, removing the previous contents of htdocs, so that I had a completely default
installation.  To that basic installation, I made some simple configuration changes, including
the enabling of SSI:

Listen: 127.0.0.1:80
Servername: localhost
<Directory "C:/Program Files/Apache Group/Apache2/htdocs">
    Options Indexes FollowSymLinks Includes
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml

Again, .html pages work fine, but the the basic .shtml file placed in the root directory does
not work at all.  If the SSI directive is removed from the file, the server serves the file
as a regular html file, without problem.

Nothing appears in the error log, even with the Loglevel set to "debug".
(Is there some other "simple" instrumentation that can be turned on??)

The two browers that I routinely use are IE 6 and Mozilla's Firefox 0.8.  Using IE, whatever
is returned for a .shtml page causes the "Page cannot be displayed / cannot find server" to
be displayed.  For Firefox, absolutely nothing happens when a .shtml page is requested from
the Apache server. 

I see that the "download page" for the Windows version say that the XP SP1 patch is REQUIRED
to solve a potential socket-sharing problem that nominally has the same generic symptoms of
my problem.   I had been successfully operating WITHOUT SP1 (one of my main fears being the
introduction of problems just like this....), but since it specifically mentioned a bug that
I could be experiencing, I decided to "bite the bullet" and install the SP1 update.  I also
installed several security-related patches.

The result: same problem.

(The download page also "recommends" disabling QoS on sockets, but does not offer any clues
about how this is done, or whether it is a source of problems.)

In desperation, I decided to try a new Apache installation, this time with the older 1.3.29
version.  I made the three changes to the httpd.conf (Options, AddType and AddHandler) and
the SSI worked like a charm!

Bolstered by that success, I did a completely new installation of 2.0.49, but had no success.
 So, for now, I am using 1.3.29....

I have also noted an (unrelated?) problem with Restarting the server (from the Apache Monitor).
 If I use the "Restart" option, the server appears to restart (one of the Apache processes
disappears and is replaced by a new process), but the server basically "unavailable".  Any
request for a web page times out.  However, if the the server is fully stopped and then separately
started, there is no problem.

Again, version 1.3.29 has no problem with Restarting.


Mime
View raw message