httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jos...@slive.ca>
Subject Re: [users@httpd] error 404 error WITH a trailing slash at end of file name
Date Fri, 30 Apr 2004 12:48:22 GMT

On Thu, 29 Apr 2004, Robert Abbate wrote:

> Hi. I just upgraded to a new server of Redhat Enterprise 3.0 (apache
> 2.0.46 ) and now when I request a URL like this:
>
> http://mysite.com/index.html/329009230/
>
> it gives error 404 NOT FOUND errors even though it will work like this:
> http://mysite.com/index.html
> http://mysite.com/index.html?/329009230/
>
> I used to be able to put trailing slashes at the end file names I requested
> and they worked great on my previoius installation of Apache 1.3
>
> I use the trailing slashes to track my session IDs, and would prefer to keep
> it that way and not have to use the ? mark.
>
> Is there an Apache configuration that can allow the above to work? Anyone
> have any suggestions?

See:
http://httpd.apache.org/docs-2.0/mod/core.html#acceptpathinfo

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message