httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jos...@slive.ca>
Subject Re: [users@httpd] Question on Perl path in CGI scripts
Date Fri, 09 Apr 2004 21:59:58 GMT

On Fri, 9 Apr 2004, Bruce H wrote:
> The problem is that Xitami, when running perl scripts, didn't care about the
> first line of the script on Windows, so it always just ran Perl where ever it
> was.  However, Apache is much more picky about this and will not run the scripts
> that have "#!/usr/bin/perl" at the top due to the path being different on my
> windows box.  I don't want to modify this line in the scripts depending on the
> location since that would be very time consuming and prone to errors.  I
> typically just use the local copy for testing fixes and enhancements before
> uploading them to the production site.  I've tried creating a folder structure
> on all my local hard drives that equates to \usr\bin and put a perl.bat file in
> there that would launch perl from the proper location, but that doesn't work.

It should work if you do it correctly.  But you've given us no details on
what went wrong.

The other alternative is the ScriptInterpreterSource directive:
http://httpd.apache.org/docs-2.0/mod/core.html#scriptinterpretersource

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message