httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jos...@slive.ca>
Subject Re: [users@httpd] 2.0.40 issue
Date Fri, 02 Apr 2004 15:31:08 GMT

On Fri, 2 Apr 2004, John Kolvereid wrote:

> Hi again,
>     Seems that when I try to access a directory off DocumentRoot w/
> ServerName of IPaddress/ Apache then goes to the IPaddress which means
> that it goes back to the internet and comes back - which seems to me a
> waste of resources, since it is already at the location and only needs
> to drop down 1 directory.  Any thoughts?
>
> John Kolvereid wrote:
>
> > Hi,
> >     Seems to be a ServerName issue as you mentioned.  It works w/ the IP
> > address/ but not the URL/.
> > This is perhaps because the server is pointed to by www.namesecure.com and not
> > a legit URL.  Unfortunately, the IP address is subject to change on a regular
> > basis because it uses a dynamic IP address.
> > Is there a way to avoid the issue by setting the ServerName to some local
> > address or something that doesn't change.  Thx.

[Please trim quotes and don't top-post.  Thanks.]

Apache must send a redirect when you request a directory without the
trailing slash.  Otherwise all relative url references would be incorrect.
It is not a "waste of resources".  If you want to avoid it, simply use the
URL with the trailing slash already included.

You can probably fix your problem by using "UseCanonicalName off" in
httpd.conf so that Apache will redirect to the same hostname that was used
in the request.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message