httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robinson, Josie M." <josie.robin...@railinc.com>
Subject RE: [users@httpd] Problems Configuring Apache Server
Date Fri, 16 Apr 2004 13:31:14 GMT
Bill, I don't do apache on Windows but unix, however having said that it
sounds like your DocumentRoot directory, in your case "/var/www/html" is
not properly defined.  You have the directory set but there is something
wrong with the permissions on this folder.  Does it exist, is it write
capable, etc.  When I get this error, it is always that this is not
defined correctly.  

For example, from the sample httpd.conf file you would need something
like this for your directory /var/www/html.  Substitute this for
/usr/local/apache/htdocs.  

DocumentRoot "/usr/local/apache/htdocs"

<Directory "/usr/local/apache/htdocs">
Options FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
    Allow from all
</Directory>

I hope this helps.  josie

-----Original Message-----
From: Bill Gillespie [mailto:bill@gillespie.ca] 
Sent: Thursday, April 15, 2004 11:53 PM
To: users@httpd.apache.org
Subject: [users@httpd] Problems Configuring Apache Server

Hello All.  I am new to this list, in the past I have been able to fix
problems with the help of the local (Vancouver, BC) Linux users group. 
But so far we are stumped.

I am having similar problems encountered by other users when trying to
access the server, I get the response:

"Forbidden
You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use
an ErrorDocument to handle the request."

I have read other threads but am still stumped so I decided to post my
httpd.conf as well as log entries.  I have been through the usual
suspects file/directory permissions, paths, etc, so far no resolve.  I
even get the same response when I try http://www.mydomain.ca/index.html.

Typical entry from access_log:
24.87.94.208 - - [15/Apr/2004:19:32:31 -0700] "GET / HTTP/1.1" 403 462
"-" "Moz$24.87.94.208 - - [15/Apr/2004:19:32:39 -0700] "GET / HTTP/1.1"
403 462 "-" "Moz$24.87.94.208 - -

Typical entry from error_log:
[Thu Apr 15 19:32:31 2004] [error] [client 24.87.94.208] (13)Permission
denied:$[Thu Apr 15 19:32:39 2004] [error] [client 24.87.94.208]
(13)Permission denied:

I am running Apache 2.0.48 on Fedora Core 1.  I have been running an
Apache server since 1997, this is frustrating.

I would sincerely appreciate any & all help, especially from other
posters who have solved the problem.

Thanks, Bill Gillespie
Vancouver, BC Canada



 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message