httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Milan Andric <mand...@eecs.berkeley.edu>
Subject Re: AW: [users@httpd] Apache 2 on Solaris 5.8: Can not load modules
Date Wed, 28 Apr 2004 17:44:00 GMT
On Wed, Apr 28, 2004 at 08:36:13AM +0200, Skladovs, Victor wrote:
> 
> 
> sorry, but just to summarize; your apache works when you don't load
> mod_status.so? 
> 
> Yes.
> 
> what's in the error log? 
> 
> No logs created. Apache can not be started with a message
> 
> bash-2.03# ./apachectl start
> Syntax error on line 250 of /usr/local/apache2/conf/httpd.conf:
> Cannot load /usr/local/apache2/modules/mod_status.so into server: ld.so.1: /usr/
> local/apache2/bin/httpd: fatal: relocation error: file /usr/local/apache2/module
> s/mod_status.so: symbol __floatdisf: referenced symbol not found
> bash-2.03# cd ../modules/
> 
> also, output from 
> # ldd /usr/local/apache2/bin/httpd 
> might be good to know.
> 
> bash-2.03# ldd httpd
>         libz.so.1 =>     /usr/lib/libz.so.1
>         libaprutil-0.so.0 =>     /usr/local/apache2/lib/libaprutil-0.so.0
>         libexpat.so.0 =>         /usr/local/apache2/lib/libexpat.so.0
>         libapr-0.so.0 =>         /usr/local/apache2/lib/libapr-0.so.0
>         libsendfile.so.1 =>      /usr/lib/libsendfile.so.1
>         librt.so.1 =>    /usr/lib/librt.so.1
>         libm.so.1 =>     /usr/lib/libm.so.1
>         libsocket.so.1 =>        /usr/lib/libsocket.so.1
>         libnsl.so.1 =>   /usr/lib/libnsl.so.1
>         libresolv.so.2 =>        /usr/lib/libresolv.so.2
>         libdl.so.1 =>    /usr/lib/libdl.so.1
>         libpthread.so.1 =>       /usr/lib/libpthread.so.1
>         libc.so.1 =>     /usr/lib/libc.so.1
>         libaio.so.1 =>   /usr/lib/libaio.so.1
>         libmp.so.2 =>    /usr/lib/libmp.so.2
>         libthread.so.1 =>        /usr/lib/libthread.so.1
>         /usr/platform/SUNW,Sun-Blade-100/lib/libc_psr.so.1

also, if you haven't already try gmake rather than solaris make.

well, here's a shot in the dark :

# cd httpd-2.0.49/
edit build/config_vars.mk and add -lgcc_s to EXTRA_LIBS like
EXTRA_LIBS = -lz -lssl -lcrypto -lgcc_s
# gmake clean
# gmake 

check to see if -lgcc_s is getting passed in to gcc ... ?

-- 
Milan

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message