httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bo Boe <boboe...@yahoo.com>
Subject Re: [users@httpd] Vhost configuration problem
Date Wed, 28 Apr 2004 08:57:49 GMT
Thanks, that seems to work when you include the SSL options, but now I don't want the ssl host
to listen on port 443 but on port 1025 for example. I would expect that one only has to change
the port numbers and that the follwing vhost file would work:
 

<VirtualHost 192.168.0.5:80>

Serveradmin webmaster@mydomain.com

Redirect / https://virtualhost2.mydomain.com:1025 

Servername virtualhost1.mydomain.com

Serveralias virtualhost1

ErrorLog logs/virtualhost1-redirect-error_log

CustomLog logs/virtualhost1-redirect-access_log common

</Virtualhost>

<VirtualHost 192.168.0.6:1025>

Serveradmin webmaster@mydomain.com

Documentroot /var/www/vhosts/virtualhost2.mydomain.com/squirrelmail

Servername virtualhost2.mydomain.com

Serveralias virtualhost2

SSLEngine on

SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL

SSLCertificateFile conf/ssl/virtualhost2_server_cert.pem

SSLCertificateKeyFile conf/ssl/virtualhost2_server_key.pem

SSLCertificateChainFile conf/ssl/cacert.pem

SSLCACertificatePath conf/ssl

SSLCACertificateFile conf/ssl/cacert.pem

ErrorLog logs/virtualhost2-error_log

CustomLog logs/virtualhost2-access_log common

Options Indexes Includes FollowSymLinks

</Virtualhost>

 
But this does not seem to work! ;-(
 
 
 
 
 

 
Joshua Slive <joshua@slive.ca> wrote:

On Mon, 26 Apr 2004, Bo Boe wrote:

> I am trying to set up a machine with multiple vhosts
> running on it all having their own ip address. I tried
> the following configuration file, but the virualhost2
> does not seem to be working. Could anyone indicate
> what I am doing wrong?
>
> I am running apache 2.0.48 on a gentoo linux box.
>
> here is my vhost.conf file:

> #virtualhost 2
> NameVirtualHost 192.168.0.6:443
>
> 
> Serveradmin webmaster@mydomain.com
> Documentroot /var/www/vhosts/virtualhost2
> Servername virtualhost2.mydomain.com
> Serveralias virtualhost2
> ErrorLog logs/virtualhost2-error_log
> CustomLog logs/virtualhost2-access_log common
> Options Indexes Includes FollowSymLinks
> 

A couple issues here:

1. The NameVirtualHost directive is used *only* for name-based virtual
hosts. You don't want that for IP or Port based virtual hosts.

2. Judging from the port number, you appear to want to run SSL on the
second virtual host. But it doesn't appear that you have actually
activated SSL.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
" from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

		
---------------------------------
Do you Yahoo!?
Win a $20,000 Career Makeover at Yahoo! HotJobs 
Mime
View raw message