httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Milan Andric <mand...@eecs.berkeley.edu>
Subject Re: AW: [users@httpd] Apache 2 on Solaris 5.8: Can not load modules
Date Tue, 27 Apr 2004 19:11:46 GMT
On Tue, Apr 27, 2004 at 01:56:40PM +0200, Skladovs, Victor wrote:

> > bash-2.03# ldd -d mod_status.so
> >         libc.so.1 =>     /usr/lib/libc.so.1
> >         libdl.so.1 =>    /usr/lib/libdl.so.1
> >         symbol not found: ap_extended_status            (./mod_status.so)
> >         symbol not found: ap_my_generation              (./mod_status.so)
> >         symbol not found: ap_scoreboard_image           (./mod_status.so)
> >         /usr/platform/SUNW,Sun-Blade-100/lib/libc_psr.so.1
> 
> That's to be expected: apache itself exports those symbols, and
> is not in your library path, so ldd doesn't see it.
> ---------------------------------------------
> What must I do to fix it?
> Thanx!
> 
> ----------------------------------------------

sorry, but just to summarize; your apache works when you don't load
mod_status.so? what's in the error log? also, output from 
# ldd /usr/local/apache2/bin/httpd 
might be good to know.

-- 
Milan

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message