httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Ryerse <mikerye...@yahoo.com>
Subject [users@httpd] noobquestion: building Apache with the options it already is built with
Date Fri, 16 Apr 2004 21:26:17 GMT
Hi,

I currently have Apache 1.3.27 installed on Redhat 7.3.  I am
considering upgrading to 1.3.29 for several reasons, and want to make
sure that when I execute ./configure for 1.3.29, that I execute it
with the same options as it was executed with for 1.3.27.  
I know that with php you can do a phpinfo() to know the options php
was built with, but I have had a hard time finding out how to know
what options Apache was built with.

The reasons that I want to upgrade are:
1) Security updates
2) I am having problems upgrading to PHP-4.3.5 (note, I am not
directing the issue below to this list, I am just including this so
that you can understand why I am wanting to rebuild/upgrade Apache):

I am trying to upgrade to PHP-4.3.5, and it was complaining that cURL
was not 7.9.8 or later, so I downloaded cURL 7.11.1 not realizing I
was downloading the SSL version, which required a newer version of
OPENSSL, so I downloaded a newer version of OPENSSL and compiled it,
then tried compiling cURL again but it didn't work still, which is
when I realized I didn't have the regular version of cURL (I had the
ssl version), so I downloaded the regular version of cURL 7.11.1 and
then found out that PHP-4.3.5 didn't like that version (which
apparently 4.3.6 just fixed), so I downloaded cURL 7.10.8 and PHP
finally accepted that and fully compiled w/o any errors.
However, when I try starting apache, I get the following error:

Apr 16 08:47:45 httpd: Syntax error on line 264 of
/etc/httpd/conf/httpd.conf:
Apr 16 08:47:45 httpd: Cannot load /usr/lib/apache/libphp4.so into
server: /usr/lib/apache/libphp4.so: undefined symbol:
OPENSSL_add_all_algorithms_noconf

And to your humor, I did not back up libphp4.so, so until I get this
fixed, php is commented out in httpd.conf on my server.

I've done some research on this error and beleive it to be caused by
one of two things:
1) The version of OPENSSL that I am compiling into PHP is not the
same version that is compiled into Apache, or
2) The directory that I am passing to ./configure --with-openssl for
php does not contain the correct path to the newer version of OPENSSL
that I downloaded.


	
		
__________________________________
Do you Yahoo!?
Yahoo! Tax Center - File online by April 15th
http://taxes.yahoo.com/filing.html

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message