httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Billy Bacon <bi...@billybacon.com>
Subject RE: [users@httpd] Error trying to start apache with ssl
Date Fri, 09 Apr 2004 17:29:31 GMT
> did you try recompiling?
No. Do you mean running 'make install' again?

> what compiler did you use?
Sun C Compiler

> what version of apache?
2.0.49

> what does ldd /usr/local/apache2/bin/httpd return?

	libz.so.1 =>	 /usr/lib/libz.so.1
	libaprutil-0.so.0 =>	 /usr/local/apache2/lib/libaprutil-0.so.0
	libexpat.so.0 =>	 /usr/local/apache2/lib/libexpat.so.0
	libapr-0.so.0 =>	 /usr/local/apache2/lib/libapr-0.so.0
	libsendfile.so.1 =>	 /usr/lib/libsendfile.so.1
	librt.so.1 =>	 /usr/lib/librt.so.1
	libm.so.1 =>	 /usr/lib/libm.so.1
	libsocket.so.1 =>	 /usr/lib/libsocket.so.1
	libnsl.so.1 =>	 /usr/lib/libnsl.so.1
	libresolv.so.2 =>	 /usr/lib/libresolv.so.2
	libpthread.so.1 =>	 /usr/lib/libpthread.so.1
	libdl.so.1 =>	 /usr/lib/libdl.so.1
	libc.so.1 =>	 /usr/lib/libc.so.1
	libucb.so.1 =>	 /usr/ucblib/libucb.so.1
	libelf.so.1 =>	 /usr/lib/libelf.so.1
	libaio.so.1 =>	 /usr/lib/libaio.so.1
	libmd5.so.1 =>	 /usr/lib/libmd5.so.1
	libmp.so.2 =>	 /usr/lib/libmp.so.2
	libthread.so.1 =>	 /usr/lib/libthread.so.1
	/usr/platform/SUNW,Ultra-60/lib/libc_psr.so.1
	/usr/platform/SUNW,Ultra-60/lib/libmd5_psr.so.1


Thanks for any help!!!

- Billy -

> -------- Original Message --------
> Subject: Re: [users@httpd] Error trying to start apache with ssl
> From: "Milan Andric" <mandric@eecs.berkeley.edu>
> Date: Fri, April 09, 2004 9:49 am
> To: users@httpd.apache.org
>
> On Fri, Apr 09, 2004 at 09:17:13AM -0700, Billy Bacon wrote:
> > I'm receiving the following error when I try to start Apache with SSL
> via this command:
> > /usr/local/apache2/bin/apachectl startssl
> >
> >
> > Syntax error on line 44 of /usr/local/apache2/conf/httpd.conf:
> > Cannot load /usr/local/apache2/modules/mod_ssl.so into server:
> ld.so.1: /usr/local/apache2/bin/httpd: fatal:
> > relocation error: file /usr/local/apache2/modules/mod_ssl.so: symbol
> X509_free: referenced symbol not found
> >
> > My /usr/local/apache2/bin/envvars file looks like this....
> >
> >
> LD_LIBRARY_PATH="/usr/local/apache2/lib:/usr/local/apache2/modules:/usr/local/ssl/lib:$LD_LIBRARY_PATH"
> > export LD_LIBRARY_PATH
> >
> > Can someone point me in the right direction?
>
> did you try recompiling?
> what compiler did you use?
> what version of apache?
> it doesn't look like an LD issue ...
> what does ldd /usr/local/apache2/bin/httpd return?
>
> --
> Milan
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server
> Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message