httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Milan Andric <mand...@eecs.berkeley.edu>
Subject Re: [users@httpd] Error trying to start apache with ssl
Date Fri, 09 Apr 2004 16:49:43 GMT
On Fri, Apr 09, 2004 at 09:17:13AM -0700, Billy Bacon wrote:
> I'm receiving the following error when I try to start Apache with SSL via this command:
> /usr/local/apache2/bin/apachectl startssl
> 
> 
> Syntax error on line 44 of /usr/local/apache2/conf/httpd.conf:
> Cannot load /usr/local/apache2/modules/mod_ssl.so into server: ld.so.1: /usr/local/apache2/bin/httpd:
fatal:
> relocation error: file /usr/local/apache2/modules/mod_ssl.so: symbol X509_free: referenced
symbol not found
> 
> My /usr/local/apache2/bin/envvars file looks like this....
> 
> LD_LIBRARY_PATH="/usr/local/apache2/lib:/usr/local/apache2/modules:/usr/local/ssl/lib:$LD_LIBRARY_PATH"
> export LD_LIBRARY_PATH
> 
> Can someone point me in the right direction?

did you try recompiling?
what compiler did you use?
what version of apache?
it doesn't look like an LD issue ...
what does ldd /usr/local/apache2/bin/httpd return?

--
Milan

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message