httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Gonzalez <t...@tuxcafe.com>
Subject Re[2]: [users@httpd] Init Apache
Date Thu, 15 Apr 2004 19:07:40 GMT
Hello Milan,

Thursday, April 15, 2004, 11:48:02 AM, you wrote:

MA> On Thu, Apr 15, 2004 at 10:38:53AM -0500, David Gonzalez wrote:

MA> well, i think alot depends on your OS and how it's setup, but one thing I did
MA> was just make a copy of apachectl and append '-DSSL' to the start case so for
MA> example, /etc/init.d/apachectl is called by the init scripts, it's equivalent
MA> to saying 'apachectl startssl'. 

SuSE  9.0  and i use chkconfig to --add --set things  i don't know the
way rc scripts work and don't wanna mess them up.

my apachectl loks like this:

case $ARGV in
start|stop|restart|graceful)
    $HTTPD -k start -DSSL  ### I added this line
    ERROR=$?
    ;;
startssl|sslstart|start-SSL)
    $HTTPD -k start -DSSL
    ERROR=$?
    ;;

The issue is that:

1. It does not start SSL mode
2. Whenever i try a restart stop graceful whatever it gives me

xaero:# /etc/init.d/apache restart
httpd (pid 8669) already running

So what can be done?...

Thanks for the abpve info anyway :)

-- 
Best regards,
 David                            mailto:test@tuxcafe.com



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message