httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rodrigo Campos" <rodr...@geekbunker.org>
Subject Re: [users@httpd] mod_rewrite tricky problem
Date Thu, 22 Apr 2004 21:41:59 GMT
You may try something like this:

RewriteEngine  on
RewriteRule    ^/~user/STABLE/(.*)    http://your-server-hostname/~user/$1
[R=permanent,L]
RewriteCond    ${REQUEST_URI}    ^/~user/
RewriteRule    !^/~user/STABLE/(.*)    /path/to/STABLE/$1

Try to raise the RewriteLogLevel to 3 (or more) in order to discover what
mod_rewrite is doing. :-)

Regards,


--
Rodrigo Campos
http://geekbunker.org/rodrigo/?sig
"If you graph the numbers of any system, patterns emerge."
----- Original Message ----- 
From: "Alexis Huxley" <ahuxley@gmx.net>
To: <users@httpd.apache.org>
Sent: Thursday, April 22, 2004 5:14 PM
Subject: [users@httpd] mod_rewrite tricky problem


> Hi, I have a website and under it URL ~user/ Under this I have a STABLE
> and UNSTABLE subdirectory.  STABLE is the public one, UNSTABLE where
> I make updates before going public.
>
(diet quote)


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message