httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lewis Skolnick" <tril...@hotmail.com>
Subject [users@httpd] Weird worker behavior
Date Sat, 13 Mar 2004 01:24:43 GMT
Hey all,

Still trying to get that worker MPM running on FreeBSD.  Hacked it so that 
we're using linux-type atomic operations instead of FreeBSD, which shouldn't 
really change anything from the functionality standpoint.

Get this, though! -- when I run the server with worker, a client attempting 
to connect hangs just until I kill the server, at which point it returns the 
page!  Technically, we only get to process_socket in worker.c after we 
receive a SIGTERM.  Which is really quite weird.

Anyway, the server runs fine with -DONE_PROCESS or -DNO_DETACH, but executes 
this really strange behavior otherwise.  AcceptMutex is an flock.

Anyone know what's up with this freaky problem?

Thanks, and have a good weekend.

Lewis

_________________________________________________________________
Learn how to help protect your privacy and prevent fraud online at Tech 
Hacks & Scams. http://special.msn.com/msnbc/techsafety.armx


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message