httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From LeeAnn Pultz <lee...@sesame.com>
Subject [users@httpd] Apache 2.0.48 weirdness
Date Wed, 17 Mar 2004 06:07:14 GMT
Hi!

I am attempting to compile Apache 2.0.48 on to my Red Hat Linux ES 3 
machine, and keep getting the following error when I try to "make" -

server/.libs/libmain.a(exports.o)(.data+0xb48): undefined reference to 
`apr_threadkey_private_delete'
collect2: ld returned 1 exit status
make[1]: *** [httpd] Error 1
make[1]: Leaving directory `/home/sesame/installs/httpd-2.0.48'
make: *** [all-recursive] Error 1

I have searched everywhere I can see, and nobody seems to have my problem :)

Here's what I have done so far:

- tried with simply ./configure

- tried with  ./configure --prefix=/usr/local/extraview/apache-2.0.48 
--enable-mods-shared=max --enable-ssl=shared 
--with-ssl=/usr/local/openssl-0.9.7c

- tried with  ./configure --prefix=/usr/local/extraview/apache-2.0.48 
--enable-mods-shared=max --enable-ssl=shared 
--with-ssl=/usr/local/openssl-0.9.7c 
--with-apr=/usr/local/apr-0.9.4/bin/apr-config 
--with-apr-util=/usr/local/apr-util-0.9.4/bin/apu-config

after installing apr-0.9.4 and apr-util-0.9.4 rpm's

This is a very minimal install of Red Hat - it's at our new colocation 
facility, and we asked them to do a minimal install, with development 
tools, so that we wouldn't have excess services running.  As a test, we 
installed the same version of Red Hat on a local machine, and did a fairly 
standard "development server" installation - and Apache 2.0.48 compiles 
with no problems.

rpm -q -a on the working box shows 561 rpm's installed, while the 
non-working box had 269.

Any suggestions on which rpm's might be important? Or, am I way off base, 
and there's another reason for this error?

Desperately hoping someone can say "hey, that's just *this*" so I can move 
forward!

Thanks in advance!

LeeAnn


LeeAnn Pultz
Sesame Technology
831-621-1836
leeann@sesame.com 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message