httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marty Landman <MLand...@face2interface.com>
Subject [users@httpd] suexec debugging
Date Mon, 01 Mar 2004 15:31:22 GMT
I've installed Apache_1.3.29 with suexec enabled.

On restart the error log shows:

[Mon Mar  1 10:09:18 2004] [notice] SIGHUP received.  Attempting to restart
[Mon Mar  1 10:09:19 2004] [notice] Apache/1.3.29 (Unix) mod_perl/1.29 
configured -- resuming normal operations
[Mon Mar  1 10:09:19 2004] [notice] suEXEC mechanism enabled (wrapper: 
/usr/local/apache/bin/suexec)
[Mon Mar  1 10:09:19 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)

I've got a virtualhost set up as follows:


<VirtualHost *>
         ServerName      yoyomaplayscello
         User            dad
         DocumentRoot    /mnt/web/guide/howami/www
         <Directory "/mnt/web/guide/howami/www">
                 Options Indexes FollowSymLinks
                 Options +Includes +ExecCGI
                 AllowOverride All
                 Options None
                 Order allow,deny
                 Allow from all
         </Directory>
         ScriptAlias     /cgibin/ "/mnt/web/guide/howami/cgibin/"
         ScriptAlias     /cgi-bin/ "/mnt/web/guide/howami/cgibin/"
         <Directory "/mnt/web/guide/howami/cgibin">
                 AllowOverride All
                 Options None
                 Order allow,deny
                 Allow from all
         </Directory>
</VirtualHost>

And ownership is:

# ls -l /mnt/web/guide/howami/cgibin/hello.cgi
-rwxr--r--    1 dad      dad           120 Dec 26 11:43 
/mnt/web/guide/howami/cgibin/hello.cgi
#

However when pointing my browser to 
http://yoyomaplayscello/cgibin/hello.cgi get a 404 error and the log shows

[Mon Mar  1 10:26:06 2004] [error] [client 192.168.0.1] Premature end of 
script headers: /mnt/web/guide/howami/cgibin/hello.cgi

On the cmd line it works fine i.e.

# perl -w /mnt/web/guide/howami/cgibin/hello.cgi
Content-type: text/html

<h1>Hello Out There</h1>
#

and static html will work off the www directory.

I understand from the manual that there is a way to have suEXEC log 
problems but don't know how or where this method's specified. This is all 
still voodoo to me. Can anyone help point me in the right direction please?

FWIW the mod_perl part of my install appears to have worked fine.

Marty Landman   Face 2 Interface Inc.   845-679-9387
FormATable  DB: http://face2interface.com/Products/FormATable.shtml
Make a Website: http://face2interface.com/Home/Demo.shtml
Free Formmailer: http://face2interface.com/Products/Formal.shtml  


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message