httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nid" <mk_s...@comcast.net>
Subject Re: [users@httpd] Apache 2.0.40 with dual nics
Date Thu, 11 Mar 2004 17:29:56 GMT
All machines...working or not have an /etc/hosts file.  All these machines
have the exact same config.

And yes....httpd works on all machines when using a browser on the machine
itself pointing to localhost...or 127.0.0.1.

I'm really not suggesting that Apache is not working per say....but that
http does not work to a box when the box has dual nics with at least 1 of
those nics being integrated to the motherboard.  Since the symptom is http
related...I thought I'd ask on the Apache boards if anyone else had seen
this.  My belief is that ultimately it is a hardware/driver issue with
integrated nics....but...again....the symptom is http related so I figured
the people here would be the ones most likely to have encountered it before.

I have also since tried disabling the onboard nic in the BIOS with no
success.

Thanks for the reply.

nid

----- Original Message ----- 
From: "James Scott" <jhs_technical@cox.net>
To: "Nid" <mk_spam@comcast.net>
Sent: Thursday, March 11, 2004 11:17 AM
Subject: Re: [users@httpd] Apache 2.0.40 with dual nics


> I'll probably make a fool of myself here but here goes.  Call this a
> shot in the dark though.
> On Wed, 2004-03-10 at 17:20, Nid wrote:
> > I'm using Red Hat 8 which includes Apache 2.0.40.  On a handful of
> > installations http does not seem to work...as in...there is no
> > response from the web server.
> Is this test external or internal.  Meaning if you use a browser on the
> machine does it respond connecting to localhost?  If it does the server
> is working.
> >   On the installations where this has been the case....they have all
> > had more than 1 NIC installed.  I have not seen this issue with any
> > server that has just 1 nic.  However, I have installed on a dual nic
> > box where it does work.  (Keep in mind that the httpd configuration on
> > all of these boxes is identical.)  So far...the only thing that I can
> > find in common between the boxes that don't work is that 1 of the nics
> > is integrated into the motherboard.  I have tried the following with
> > no success:
> In the one that does work does it have a /etc/hosts file and do the
> others not?
> >
> > Deactivating 1 of the NICs in the network config
> > Removing 1 of the NICs in the network config
> > Specifying the IP in the conf file  (ie....Listen  xxx.xxx.xxx.xxx:80
> > instead of Listen 80)
> >
> > There are no error messages whatsoever in any of the log files that I
> > have seen when trying to connect to the web server.  So, I was
> > wondering if anyone else had run into a similar issue and if you found
> > a solution to it.  All the servers I've installed on have been of
> > varying hardware.  Again, I've never seen this problem with any server
> > that has only 1 nic.  It has been a problem on every server with more
> > than 1 nic with 1 exception.  The exception did not have an integrated
> > nic....while, so far as I can remember, the others did.  Thank you for
> > any help/advice.
> >
> > nid
>
>



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message