httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From BAO RuiXian <ruixian....@pp.inet.fi>
Subject Re: [users@httpd] Directory problem when accesing by IP
Date Sat, 21 Feb 2004 21:45:50 GMT


KNT wrote:

>-----BEGIN PGP SIGNED MESSAGE-----
>Hash: SHA1
>
>U|ytkownik BAO RuiXian napisaB:
>  
>
>>KNT wrote:
>>
>>Greetz to all!
>>
>>I'm new here but my Apache acts strange (at least for me). I have a
>>phpBB directory in my document root. When I access it by
>>http://localhost/phpBB/ every thing is ok. But when I write in the
>>browser http://10.9.254.233/phpBB/ (my IP in a LAN) I get a 404. Writing
>>http://10.9.254.233/ gives me {DocumentRoot}/index.html. If I don't have
>>a index,html I can manually change the directory to phpBB. I don't use
>>any DNS servers.
>>
>>
>>    
>>
>>>Interesting. Any error in your log files when you directly call
>>>10.9.254.233/phpBB/?
>>>      
>>>
>
>{Date/Time} [error] [client 10.9.254.233] File does not exist:
>/var/www/phpBB/
>  
>
Weird. Are you sure you have the 'phpBB' under '/var/www'? Also check 
your httpd.conf file to see the argument for directive DocumentRoot. You 
can also try to make a test directory to see if it works or not by 
calling 10.9.254.233/test

Best

Bao

>and that's all.
>
>- -KNT
>
>
>  
>


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message