httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Dessent <br...@dessent.net>
Subject Re: [users@httpd] Trouble Under 2.6 Kernel
Date Tue, 17 Feb 2004 01:51:58 GMT
Mitch Crane wrote:

> SuSE 9 - 2.6.2 kernel - Apache 2.0.48
> 
> Much of my site's files reside on a Windows XP share which I mount as a CIFS
> (or SMBFS, same problem occurs either way). This worked fine running the 2.4
> kernel, but using 2.6 breaks all of my images and links to data files. The
> links are valid, it's just that the server can't seem to read the files. I
> can see the files and list directories just fine.
> 
> Going back to the 2.4 kernel fixes everything. If I umount the CIFS on that
> mount point and put actual copies of those files there it works, so I assume
> this is some kind of read permission problem.
> 
> The CIFS mount seems to be working correctly. I can ftp into the machine and
> access all of the files without problems, copy files via the shell, etc.
> Apache just can't seem to read them.

Have you tried disabling 'Sendfile'?  That would be the first thing I'd
try, esp. on a network share.

Brian

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message