httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Baronian <n...@finiteautomata.com>
Subject [users@httpd] Apache Compile Questions - modules & SSL
Date Wed, 11 Feb 2004 00:31:07 GMT
Hello, I am trying to compile Apache with SSL and I would like to have 
all the modules installed also.  Which version is better to use for this 
2.0.48 or 1.3.29?  I have tried to compile both with the following 
./configure command but did not get configure to work.  I typed the 
following when trying version 2.0.48
./configure --prefix=/usr/local/apache2.0.48 --enable-mods-shared=all 
--enable-ssl --with-ssl=/usr/share/ssl
This worked for version 2.0.48 but I went into the 
/usr/local/apache2.0.48 dir and there was no conf directory nor a 
apachectl file to be found.  Why would this happen I didn't receive any 
errors or issues during configure/make/make install?   I would like to 
use 2.0.48 because I would assume that this version is the best version 
to use due to updates and patches if not version 1.3.x will do fine.

So I tried version 1.3.29 but it doesn't appear to like the configure 
syntax.  What is the correct way to compile 1.3.29 with SSL and all the 
modules?  If I leave off the --enable-module-shared=all will Apache 
default to loading some modules like mod_include?  I will need Server 
Side Includes as well as SSL?

Do I have to load mod_SSL or just SSL if I just have some secure sites 
that have certificates?

Thanks for your help.
Nick

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message