httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Dessent <br...@dessent.net>
Subject Re: [users@httpd] Help me please .. Mod_rewrite
Date Mon, 02 Feb 2004 10:34:01 GMT
Jerome Schevingt wrote:

> Now, i want the same action but without change URL. I want use Proxy.
> 
> I put into my VirtualHost:
> 
>     RewriteEngine On
>     RewriteRule ^/clients/(.+)$
> http://www-srv1.nightrain.com/cgi-bin/awstats.pl?config=$1 [P,L]

You don't need 'L' at the end there, it doesn't make any sense when used
with 'P'.

> When the user put the first url, she don't change (good ..) but the $1 don't
> work ...
> 
> My question:
>     1- He have a debug mode in mod_rewrite ?? for know what is the problems

Wouldn't it be great if there was a debugging logfile that you could
enable, and a manual to explain how to turn it on?  :-) 
http://httpd.apache.org/docs/mod/mod_rewrite.html#RewriteLog

>     2- Can i use the good config ?

Explain in more detail what happens or how it fails.  Your config looks
fine to me.  Make sure you've loaded mod_proxy.

Brian

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message