httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Orton <jor...@redhat.com>
Subject Re: [users@httpd] Help with SSL and CGI Env var export - can't get SSL_CLIENT_CERT_CHAINn values
Date Fri, 27 Feb 2004 20:08:16 GMT
On Fri, Feb 27, 2004 at 08:33:07AM -0800, Ian Huynh wrote:
> Hey Joe
> you are right in that mod_headers messed up multiple lines. I filed a bug with Apache

> http://nagoya.apache.org/bugzilla/show_bug.cgi?id=23223

Does the fix I just attached to that bug work for you?

> I WAS able to get SSL_SERVER_CERT to export as well now but the caveat is only one of
the CERT
> (either CLIENT or SERVER) will come out as a header. not both. If both are turned on,
only the 
> first directive is recognized.
> 
> 
> This sequence exports only Client Cert 
> 
> >> RequestHeader set SSLClientCert %{SSL_CLIENT_CERT}e
> >> RequestHeader set SSLServerCert %{SSL_SERVER_CERT}e
> 
> This sequence exports only Server Cert
> >> RequestHeader set SSLServerCert %{SSL_SERVER_CERT}e
> >> RequestHeader set SSLClientCert %{SSL_CLIENT_CERT}e

That's odd, I can't reproduce that.

> I could never get Client Cert chain to export. 

And that is supposed to work if you have +ExportCertData.  Confused...

joe

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message