httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geraint Jones <geraint.jo...@meirion-dwyfor.ac.uk>
Subject Re: [users@httpd] Newbie - need help with running cgi from a userdir
Date Fri, 20 Feb 2004 15:46:38 GMT
Bao - I added your suggestion to the "Userdir" block which was in 
"default-server.conf". It's a step forward because now I get an error 403 
"Access forbidden" message instead of a printout of the script. I get this in 
the error log:

[Fri Feb 20 15:40:28 2004] [error] [client 127.0.0.1] Options ExecCGI is off 
in this directory: /home/geraint/public_html/cgi-bin/inv-main.cgi

Thanks.

On Friday 20 February 2004 15:40, BAO RuiXian wrote:
> Geraint Jones wrote:
> >Just tried it - no change. I forgot to mention that my Perl CGI script
> > code is displayed. My problem is that Apache isn't executing it and the
> > instructions from the manual don't work for me. Maybe I'm missing
> > something small? Maybe there's something in the conf files I'm supposed
> > to alter that isn't mentioned in the docs? Could someone go through the
> > steps to allowing CGI to execute from a directory outside the
> > "DocumentRoot" please?
>
> You need to add the following to your userdir block in your httpd.conf:
>
>     Options +ExecCGI
>     AddHandler cgi-scirpt .pl
>
> Best
>
> Bao


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message