httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jolyon Brown <jolyonbr...@yahoo.com>
Subject [users@httpd] httpd child processes segmentation fault (11)
Date Mon, 16 Feb 2004 17:41:03 GMT
Hi

(Solaris 8, apache 1.3.29, mod_ssl-2.8.16,
openssl-engine-0.9.6l, mod_gzip 1.3.19.1a, mod_caucho
1.2.7)

I'm seeing httpd child processes die on a fairly
frequent basis. I've had a good google around without
too much success and was wondering if anyone can help.

Some background : this site uses resin for dynamic
content (hence the mod_caucho module). We're also
using Verisign Global certs and a CryptoSwift PCI card
for encryption which both work well in conjunction
with mod_ssl and openssl. Mod_gzip is used for
compression and again I have no problem here (I do
realise theres a later version of this, I haven't
tried upgrading here to see if thats the problem).

I've managed to get a truss of some of these processes
and I've included this here :

> lwp_cond_wait(0xFF1734E8, 0xFF1734F8, 0xFF16CD80)
(sleeping...)
> signotifywait()                                 = 16
>     Received signal #16, SIGUSR1, in fcntl()
[caught]
>       siginfo: SIGUSR1 pid=26775 uid=0
> lwp_sigredirect(1, SIGUSR1, 0xFE00FC6C)         = 0
> fcntl(55, F_SETLKW, 0x000ACAD0)                
Err#4 EINTR
> sigprocmask(SIG_SETMASK, 0xFF16CFB8, 0x00000000) = 0
> sigaction(SIGHUP, 0xFFBEF200, 0xFFBEF300)       = 0
> sigaction(SIGUSR1, 0xFFBEF200, 0xFFBEF300)      = 0
>     Incurred fault #6, FLTBOUNDS  %pc = 0xFED93940
>       siginfo: SIGSEGV SEGV_MAPERR addr=0xB5424E38
>     Received signal #11, SIGSEGV [caught]
>       siginfo: SIGSEGV SEGV_MAPERR addr=0xB5424E38
> sigaction(SIGSEGV, 0xFFBEEDD0, 0x00000000)      = 0
> sigprocmask(SIG_SETMASK, 0xFF16CFB8, 0x00000000) = 0
> chdir("/opt/apache/live")                       = 0
> sigaction(SIGSEGV, 0xFFBEEC50, 0xFFBEED50)      = 0
> getpid()                                        =
18841 [26775]
> getpid()                                        =
18841 [26775]
> kill(18841, SIGSEGV)                            = 0
> signotifywait()                                 = 11
> sigprocmask(SIG_SETMASK, 0xFF178CE0, 0x00000000) = 0
> sigprocmask(SIG_SETMASK, 0xFF178CE0, 0xFFBEEDC0) = 0
> lwp_sigredirect(1, SIGSEGV, 0xFFBEED3C)         = 0
> lwp_sigredirect(1, SIGSEGV, 0xFFBEED3C)        
Err#22 EINVAL
> sigprocmask(SIG_SETMASK, 0xFFBEEDC0, 0x00000000) = 0
> setcontext(0xFFBEECB0)
>     Received signal #11, SIGSEGV [default]
>       siginfo: SIGSEGV pid=18841 uid=10720
>         *** process killed *** 

the apache error_log shows this as 

[notice] child pid XXXX exit signal Segmentation fault
(11).

Anyone got any clue whats going on here? I know it's
only a notice but we're getting a few of these a
minute...

Thanks in advance.

Regards

jo brown


	
	
		
___________________________________________________________
BT Yahoo! Broadband - Free modem offer, sign up online today and save £80 http://btyahoo.yahoo.co.uk

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message