httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul" <p...@kbs.net.au>
Subject [users@httpd] Apache single active process
Date Wed, 25 Feb 2004 05:35:36 GMT

Hi Everyone,

Im running apache 1.3.28 on linux 2.6.0 and I have noticed that we only seem
to have 1 single httpd process active at any one time, regardless of server
load etc..
We have currently around 140 httpd process running under the parent httpd
process but at any point in time when I look at top or ps we see only one
process doing cpu work.
This process does work for some time, say a few minutes then another httpd
process starts doing the work, in a round-robin sort of way.

Previously (as in on 2.4.20 on our last server) apache would simply answer
incoming requests concurrently and you'd have several httpd's doing cpu
work, whereas now it seems only one of them is doing it at any one time.
Below are some stats/debugs in case this helps. Do you guys have any ideas
or have you seen this before? I tried searching your archives and mailing
lists, google etc but was unable to find any good ideas or exact cause

root     29485  0.0  0.1  4684 2008 ?        S    Feb09   1:24
/usr/local/apache/bin/httpd
nobody    7783  0.0  0.4  6732 4628 ?        S    16:35   0:00  \_
/usr/local/apache/bin/httpd
< about another 140 processes here >
nobody    7797  0.0  0.2  4708 2140 ?        S    16:35   0:00  \_
/usr/local/apache/bin/httpd
nobody    7798  0.0  0.4  6620 4476 ?        R    16:35   0:00  \_
/usr/local/apache/bin/httpd

./configure --with-layout=Apache --enable-module=ssl --enable-module=unique_
id --enable-module=rewrite --enable-shared=max

Linux web01 2.6.1-rc3 #3 SMP Tue Jan 20 11:21:53 EST 2004 i686 unknown
unknown GNU/Linux

 16:33:23  up 28 days, 15:13,  1 user,  load average: 6.78, 4.13, 3.21
201 processes: 200 sleeping, 1 running, 0 zombie, 0 stopped
CPU0 states:  49.0% user   4.0% system    0.0% nice  27.0% iowait  18.0%
idle
CPU1 states:  41.0% user  11.0% system    0.0% nice  20.0% iowait  26.0%
idle
Mem:  1033980k av, 1021368k used,   12612k free,       0k shrd,   77924k
buff
       942424k active,              14612k inactive
Swap:  498004k av,  232428k used,  265576k free                   94100k
cached

The system is a dual AMD 2800 with 1GB DDR memory

Thanks

Paul



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message