httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chuck Ouellette" <ch...@wncg.net>
Subject [users@httpd] Compiling Apache w/PHP, SSL & Oracle
Date Mon, 23 Feb 2004 16:49:43 GMT
Hi Group,

I'm new to the group but have been using Apache for many years now. I
have never had a problem until now compiling and installing Apache.
Here's my problem:
I am trying to compile Apache on a Sun Spark running SunOS 5.8 with the
following modules included, PHP, SSL with oracle support. I also
downloaded mod_perl however my Perl Scripts have worked fine with my
previous installation of Apache. I currently have Perl version 5.8
running and it seems to be working fine. (I'm not sure what mod_perl
does so if someone wants to answer that I would greatly appreciate it.) 

I have downloaded Apache_1.3.29, mod_perl-1.99_12,
mod_ssl-2.8.16-1.3.29, php-4.3.3 and openssl-0.9.7c. 
The steps I have taken to resolve my issue: 
1. I have read all the README, INSTALL files that came bundled in the
respective programs.
2. I have gone out to the respective web sites to get the latest
installation tips and updates.
3. I have tried numerous different command line arguments and
re-arranged the order of steps numerous times.

The following are the last steps I have taken, below these steps I will
list the errors I am getting:

1.	Extract the Packages:
	gzip -d -c apache_1.3.29.tar.gz | tar xvf - 
	gzip -d -c mod_ssl-2.8.16-1.3.29.tar.gz | tar xvf -
	gzip -d -c php-4.3.3.tar.gz | tar xvf - 
2.	Apply mod_ssl to Apache source tree:
		cd /mod_ssl-2.5.16-1.3.29
		./configure --with-apache=../apache_1.3.29 \
		--with-ssl=../../SSL/openssl-0.9.7c \
		--with-crt=/etc/apache/ssl.crt/server.crt \  
		--with-key=/etc/apache/ssl.key/server.key		

3.	Pre-Configure Apache for PHP4's configure step:
		cd ../apache_1.3.29
		SSL_BASE=../../SSL/openssl-0.9.7c \
		./configure -prefix=/usr/apache \
		--with-layout=Solaris \
		--enable-module=ssl \
		--enable-shared=ssl \
		--disable-rule=SSL_COMPAT \
		--enable-rule=SSL_SDBM \
		--enable-rule=SSL_EXPERIMENTAL \
		--enable-rule=SSL_VENDOR \
		--add-module=/opt/software/php/php-4.3.3 \
		--activate-module=src/modules/php4/libphp4.a \
		--enable-module=php4

4.	Configure PHP4 and apply it to the apache source tree:
		cd /opt/software/php/php-4.3.3
		CFLAGS='-O2 -I/opt/software/SSL/openssl-0.9.7c/include'
\
		./configure
-with-apache=/opt/software/apache/apache_1.3.29  \
		--with-oci8=/hosting/u01/app/oracle/product  \
		--enable-discard-path  \
		--enable-fastcgi  \
		--enable-ftp \
	make
	make install

5.	Compile and Install Apache with PHP4 and SSL:
	make
	make certificate    
	make install


when I run the commands in the above order steps 1-4 all work fine but
on step 5 I get an error that it can't find module name php4 or module
name invalid so I redo the configure step (step 3) and omit the last 3
lines 
		--add-module=/opt/software/php/php-4.3.3 \
		--activate-module=src/modules/php4/libphp4.a \
		--enable-module=php4

then it will compile without error. However when I do a httpd -l command
I only get the following output:
Compiled-in modules:
  http_core.c
  mod_so.c
suexec: disabled; invalid wrapper /usr/apache/bin/suexec

with my original configuration of apache I would get the same output
with httpd -l command excluding the suexec:disabled; invalid wrapper
/usr/apache/bin/suexec
however the suexec.disabled file exits in both versions.   Not sure how
to get rid of that error message? 

Secondly when I startup apache with the apachectl startssl command I get
the following:
[Mon Feb 23 11:26:40 2004] [warn] Loaded DSO
/usr/apache/libexec/libperl.so uses plain Apache 1.3 API, this module
might crash under EAPI! (please recompile it with -DEAPI)
/usr/apache/bin/apachectl startssl: httpd started

I'm not sure where to put the -DEAPI while compiling to eliminate this? 

I need to get this compiled with the SSL support & PHP even though I
have added the "AddModule" and AddHandler directives in the httpd.conf
file my PHP still is unrecognized when I try to run a test .php page.
Also, I am running multiple virtual hosts on this machine I would like
the PHP and SSL available to all but not necessarily needing to run them
at this time.  One final note, I previously compiled and installed the
openssl-0.9.7c even though it was omitted from the above steps. 

Any assistance with this would be greatly appreciated. I also apologize
for the length of this message however I wanted to give as much
information as possible so I could get the best assistance. 

Regards,

Chuck


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message