httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andy Kavanagh" <an...@lofi-gaming.org.uk>
Subject RE: [users@httpd] Removing an extra slash from redirected URLs
Date Sun, 22 Feb 2004 22:36:23 GMT
> The bug is quite new ;-).
> 
> > In any case, is there a way of modifying my code to
> > fix this problem?  I only have control over the htaccess 
> file, as it 
> > is a site on my ISP's servers and not my own.
> > 
> > This is my current code:
> > 
> > RewriteEngine on
> > RewriteBase   /  
> > RewriteRule   ^(.*)\.shtml$              $1      [C,E=WasHTM:yes]
> > RewriteCond   %{REQUEST_FILENAME}.php -f
> > RewriteRule   ^(.*)$ $1.php                   [S=1,R]
> > RewriteCond   %{ENV:WasHTM}            ^yes$
> > RewriteRule   ^(.*)$ $1.shtml
> 
> Yes. Preceding the replacement with the slash yourself should 
> help. Like:
> 
> RewriteRule   ^(.*)\.shtml$ /$1 [C,E=WasHTM:yes]

Hmmm.  That gives me a 500 internal server error whenever I request a .shtml
page now :(

Andy

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.592 / Virus Database: 375 - Release Date: 18/02/2004
 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message