httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jos...@slive.ca>
Subject Re: [users@httpd] Segmentation errors
Date Fri, 23 Jan 2004 16:42:55 GMT

On Thu, 22 Jan 2004, Michael A. Lewis wrote:

> I have a site that has been running for a month at least with no
> problems. Nothing on the site has changed in the last several days. I
> get a call this afternoon from one of my users that they can't see some
> of the pages. It turns out that any page that attempts (via a PHP
> script) to connect to a SQL SERVER server gets the error. I am running
> Red Hat 9.0, Apache 2.0.48, PHP 4.3.4 and Freetds 0.61. I have a script
> that consists of a mssql.connect statement only and it fails only when
> server from Apache. I can run the same script from the command line ala
> "php bad.php". I observe the same behavior using PERL. I run a perl
> command line script and it runs fine. I run he same script via apache
> and it doesn't work. Apache serves up all other pages (including
> connections to my MYSQL server).

A segmentation fault usually implies a core dump.  See the
CoreDumpDirectory directive on how to set where that goes.  And see:
http://httpd.apache.org/dev/debugging.html
for many more details on how to debug problems like these.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message