httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eimantas \"EnC\" Vaičiūnas" <eiman...@lietuvoje.lt>
Subject Re: [users@httpd] apache + oracle + php
Date Mon, 26 Jan 2004 12:38:59 GMT
Hi

I think your problem is that you start variable name with a number. 
AFAIK you can't declare variables in PHP which starts with a number.

Luis Moran Ochoa wrote:

> Hello....
> 
> I have the next problem:
> 
> I've compiled php for supporting Oracle 9. And apache supporting php....
> 
> All works fine (more or less).
> 
> I the typical script for starting apache, it's very similar to this:
> 
> $ORACLE_HOME=blahblahblah
> $ORACLE_SID=ORA
> ..... more variables.....
> case "$1" in
>  start)
>     /opt/apache/bin/apachectl startssl
>    ;;
> 
>  stop)
>      /opt/apache/bin/apachectl stop
>    ;;
> esac
> 
> 
> It works fine if you login as root and launch it using 
> /etc/init.d/apache start
> 
> But when it's executed by the init process Apache runs until you try to 
> ask for a php page
> that connects to Oracle.... Then that apache instance dies and no more 
> php+Oracle pages can
> be shown....
> 
> It seems to be a problem with the establishment of the variables.... But 
> I don't understand
> where is the diference between launching it on a term or by means of the 
> init.
> 
> Any idea?
> 
> Thank you.



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message