httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron W Morris <aaronmor...@mindspring.com>
Subject Re: [users@httpd] Running httpd on Aix (unresolved symbols)
Date Tue, 13 Jan 2004 06:45:47 GMT
Hemond, Steve wrote:
> Hi ppl,
> 
> I just compiled Apache2 on my Aix box and everything was fine. make test didn't return
any error. However, when starting httpd, I get these error messages:
> 
> rtld: 0712-001 Symbol pthread_sigmask was referenced
>       from module /usr/local/apache2/lib/libapr-0.so(), but a runtime definition
>             of the symbol was not found.
> 
> rtld: 0712-001 Symbol pthread_rwlock_unlock was referenced
>       from module /usr/local/apache2/lib/libapr-0.so(), but a runtime definition
>             of the symbol was not found.
> 
> rtld: 0712-001 Symbol pthread_rwlock_destroy was referenced
>       from module /usr/local/apache2/lib/libapr-0.so(), but a runtime definition
>             of the symbol was not found.
> 
> rtld: 0712-001 Symbol pthread_rwlock_init was referenced
>       from module /usr/local/apache2/lib/libapr-0.so(), but a runtime definition
>             of the symbol was not found.
> 
> rtld: 0712-001 Symbol pthread_rwlock_rdlock was referenced
>       from module /usr/local/apache2/lib/libapr-0.so(), but a runtime definition
>             of the symbol was not found.
> 
> rtld: 0712-001 Symbol pthread_rwlock_tryrdlock was referenced
>       from module /usr/local/apache2/lib/libapr-0.so(), but a runtime definition
>             of the symbol was not found.
> 
> rtld: 0712-001 Symbol pthread_rwlock_wrlock was referenced
>       from module /usr/local/apache2/lib/libapr-0.so(), but a runtime definition
>             of the symbol was not found.
> 
> rtld: 0712-001 Symbol pthread_rwlock_trywrlock was referenced
>       from module /usr/local/apache2/lib/libapr-0.so(), but a runtime definition
>             of the symbol was not found.
> 
> rtld: 0712-002 fatal error: exiting.
> 
> 
> 
> Can anyone explain what this is about (pthread?) and why the symbols aren't found?
> 
> Thank you very much in advance,
> 
> Best regards,
> 
> Steve Hemond
> Programmeur Analyste / Analyst Programmer
> Smurfit-Stone, Ressources Forestières
> La Tuque, P.Q.
> Tel.: (819) 676-8100 X2833
> shemond@smurfit.com 

Try "export LIBPATH=/usr/local/apache2/lib:$LIBPATH".  Then try to start.


-- 
Aaron W Morris <aaronmorris@mindspring.com> (decep)




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message