httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted <...@KI5U.net>
Subject RE: [users@httpd] Authentication ignored issue
Date Thu, 01 Jan 2004 22:20:37 GMT
Hi Sean,

It looks like  your solution may be a good work-around.  Would you mind 
publishing your change_password.html file?

Thanks, Ted

At 01:53 PM 12/31/2003 -0500, you wrote:
>I don't know if this will help your issue or not, but this is how I set up
>my Apache server (it runs on Linux but I'm guessing it should be the same
>???).
>
><Location /cgi-bin/dvlp>
>AuthName sidv-dvlp
>AuthType Basic
>AuthUserFile /msg/sidv/tas/etc/cfg/tas_users_dvlp.cfg
>Require valid-user
>ErrorDocument 401 /common/change_password.html
></Location>
>
>So, basically, any cgi script that resides under /cgi-bin/dvlp prompts the
>user for a login/password.  I also have different security privileges for
>scripts that reside under different directories.
>
>NOTE: I'm using the Location tag and not a Directory tag.
>
>Hope this helps ...
>
>-----Original Message-----
>From: Tom Holmes Jr. [mailto:tom@tomholmes.net]
>Sent: Wednesday, December 31, 2003 2:00 PM
>To: users@httpd.apache.org
>Subject: [users@httpd] Authentication ignored issue
>
>
>I have a web-site in Tomcat 4.1.29 from Apache 2.0.48 on Win2K.  I have read
>all the directions for creating security on a web-site and I have access to
>the httpd.conf file and I am *not* using .htaccess files.
>
>I have followed the directions in the How-To, and I am doing as the docs
>prescribe.  I also checked out this newsgroup for all the previous questions
>and tried various things ... each time making sure I do restart the Apache
>web-server.
>
>I modified my httpd.conf file to have this near the beginning: <Directory
>"C:\web\jakarta-tomcat-4.1.29\webapps\test">
>  AuthType Basic
>  AuthName "By Invitation Only"
>  AuthGroupFile c:\web\Apache2\password\groups
>  AuthUserFile  c:\web\Apache2\password\passwords
>  Require group mygroup
></Directory>
>
>Instead of having the 'AuthGroupFile' and the 'Require group mygroup' I
>tried 'Require valid-user' and this still did not work.
>
>Any help would be much appreciated.   Thanks.
>
>                          Tom
>
>
>---------------------------------------------------------------------
>The official User-To-User support forum of the Apache HTTP Server Project.
>See <URL:http://httpd.apache.org/userslist.html> for more info. To
>unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
>For additional commands, e-mail: users-help@httpd.apache.org
>
>---------------------------------------------------------------------
>The official User-To-User support forum of the Apache HTTP Server Project.
>See <URL:http://httpd.apache.org/userslist.html> for more info.
>To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
>For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message