httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Andersson" <rob...@profundis.nu>
Subject Re: [users@httpd] Virtual directory not recognized...
Date Fri, 16 Jan 2004 08:37:17 GMT
Ted wrote:
> The main domain is http://www.intel-source.com
> One of the sub-domains is http://sitrep.intel-source.com

You cannot do name-based virtual host together with this "domain forwarding"
crap. Name-based virtual hosts depends on that the client sends a Host:
header, containing the actual hostname.

Take a look at the source when you browse to those links above, and you will
see this:

    ...
    <frameset frameborder=0 framespacing=0 border=0 rows="100%,*">
        <frame name="TOPFRAME" src="http://66.12.9.126:26788" noresize>
    </frameset>

This is not a document servered from you, but the host that does your
"domain forwarding". As you see, it will translate the actual hostname
(www.intel-source.com) to the IP, and thus the hostname is lost and Apache
cannot distinguish them anymore.

The bottom line is, "domain forwarding" (at least done this way) is plain
silliness. Get your domains' A-record pointing directly at your computer,
which is currently pointing at your "domain forwarder".

</rant>

Regards,
Robert Andersson


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message