httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Andersson" <rob...@profundis.nu>
Subject Re: [users@httpd]Half Resolved - Virtual Sites not showing up on network
Date Fri, 09 Jan 2004 07:10:26 GMT
Trevor Rhodes wrote:
> I was going to
>
> http://192.168.0.43
>
> and getting the apache screen, but when I added something like
>
> /dural
>
> to the end so I could get to one of the virtual sites, it was changing
from
> 192.168.0.43 to 127.0.0.1 and was looking on my machine instead.
>
> So, do I now have to look for all occurences of localhost and/or 127.0.0.1
and
> change them to 192.168.0.43 ?

Yes, you might also want to try to avoid specifying the IP where it is
possible. But, what you want here is:
    UseCanonicalName Off
 (http://httpd.apache.org/docs-2.0/mod/core.html#usecanonicalname)

This controls what hostname Apache will use when building an absolute URI
when it needs to redirect to it self. 'Off' means to use whatever hostname
the client used to make the original request, rather than the configured
ServerName.

Regards,
Robert Andersson


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message