httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lauri_Doni...@vrtx.com
Subject [users@httpd] Auth_LDAP problem
Date Wed, 17 Dec 2003 19:14:37 GMT




I have seen many posts about people having problems compiling auth_ldap and
ldap with Apache but no solutions (that have worked for me).  Here are the
details:

Solaris 2.8 Generic 108528-16
Apache 2.0.43  (willing to try another version if necessary!)
Perl 5.6.1
Netscape SDK 5.0 (want to use SSL)

First of all, has anyone successfully been able to use LDAP authentication
with Apache 2.0???   I know it's one of the "experimental" modules so I
thought I should ask this first.

I am able to configure the Makefile using the following command:

./configure --prefix=/usr/local/apache2
--with-perl=/usr/local/lib/perl5/5.6.1
---enable-modules=auth_ldap ldap perl auth usertrack setenvif proxy cgi
userdir
env mod_mime status include autoindex dir asis actions alias access
log_config

When I run make and get to the LDAP module, I get the following output:

make[3]: Entering directory `/usr/local/httpd-2.0.43/modules/experimental'
/bin/bash /usr/local/httpd-2.0.43/srclib/apr/libtool --silent
--mode=compile gcc
  -g -O2 -pthreads    -DSOLARIS2=8 -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT
-DAP_
HAVE_DESIGNATED_INITIALIZER   -I/usr/local/httpd-2.0.43/srclib/apr/include
-I/us
r/local/httpd-2.0.43/srclib/apr-util/include -I/usr/local/httpd-2.0.43
/srclib/ap
r-util/xml/expat/lib -I. -I/usr/local/httpd-2.0.43/os/unix
-I/usr/local/httpd-2.
0.43/server/mpm/prefork -I/usr/local/httpd-2.0.43/modules/http
-I/usr/local/http
d-2.0.43/modules/filters -I/usr/local/httpd-2.0.43/modules/proxy
-I/usr/local/ht
tpd-2.0.43/include -I/usr/local/httpd-2.0.43/modules/dav/main  -c
mod_auth_ldap.
c && touch mod_auth_ldap.lo
mod_auth_ldap.c:82:2: #error mod_auth_ldap requires APR-util to have LDAP
suppor
t built in

But I have APR-util running (in fact Apache rebuilds it).  I have run into
other errors trying different methods as well, so again, has anyone been
able to get this to work?  If not, has anyone been able to get it to work
with auth-ldap 1.6.0 (I've tried that as well).  If not, should I go back
to version 1 of Apache??

Thanks so much!


------------------------
Lauri S. Doniger
Sr. Systems Engineer
Vertex Pharmaceuticals, Inc
617-444-6509



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message