httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Liu David" <david...@hotmail.com>
Subject [users@httpd] Apache and mod_proxy do extra decode on URL?
Date Wed, 10 Dec 2003 17:47:54 GMT
Here's what has been observed:

We are using Apache 2.0.47 + mod_proxy:

    ProxyRequests Off
    ProxyPass / http://127.0.0.1:8081/
    ProxyPassReverse / http://127.0.0.1:8081/

But when we issue one request with partially URL encoded:

     /equipment/view-equipment-detail.html.arg=equipmentPK%3DEq1.6A864V
                                                          ^^^   
and the mod_proxy (or Apache core) decoded the %3D and passes it to 
127.0.0.1:8081

[Wed Dec 10 10:05:20 2003] [debug] proxy_http.c(221): proxy: HTTP 
connecting 
http://127.0.0.1:8081/equipment/view-equipment-detail.html.arg=equipmentPK=Eq1.6A864V 
to 127.0.0.1:8081
                                                                            
                                                                           
^
                                
This causes trouble. IMHO, mod_proxy should pass the URL transparently.

Is this the desirable behavior of Apache 2.0.47 + mod_proxy? Could anybody 
tell me whether i missing anyting?

Thanks in advance,

David Liu

Point2 Technologies Inc.

_________________________________________________________________
与联机的朋友进行交流,请使用 MSN Messenger: http://messenger.msn.com/cn 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message